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Copyright 
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The information contained in this document remains the sole property of Kongsberg Mesotech Ltd. No part of 
this document may be copied or reproduced in any form or by any means, and the information contained 
within it is not to be communicated to a third party, without the prior written consent of Mesotech Ltd. The 
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Disclaimer 
Kongsberg Mesotech Ltd. endeavours to ensure that all information in this document is correct and fairly 
stated, but does not accept liability for any errors or omissions. 

Warning 
The equipment to which this manual applies must only be used for the purpose for which it was 
designed. Improper use or maintenance may cause damage to the equipment and/or injury to 
personnel. The user must be familiar with the contents of the appropriate manuals before attempting to 
install, operate or work on the equipment. 
Kongsberg Mesotech Ltd. disclaims any responsibility for damage or injury caused by improper 
installation, use or maintenance of the equipment. 

Support information 
If you require maintenance or repair, contact your local dealer. You can also contact us by phone at: 
 +1 604 468 8144 or by email at: km.support.vancouver@km.kongsberg.com. If you need information 
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distributors. 



   

922-20007004/1.5  
10.JUNE.2016 © Kongsberg Mesotech Ltd 

Feedback 
To assist us in making improvements to the product and to this manual, we welcome comments and 
constructive criticism. Please send all such – in writing by Email to: alan.zhao@km.kongsberg.com 

 





  ©2016, Kongsberg Mesotech Ltd. 

922-20007004/1.5                1 

Table of contents 
ABOUT THIS MANUAL ................................................................................................... 2 

Purpose .............................................................................................................................. 2 
Target audience ................................................................................................................. 2 
Licence information .......................................................................................................... 2 
Software version ............................................................................................................... 2 
Registered trademarks ....................................................................................................... 3 

M3 BATHY .......................................................................................................................... 4 
System description ............................................................................................................ 5 
System diagram ................................................................................................................. 5 
Support information .......................................................................................................... 6 

GETTING STARTED ......................................................................................................... 7 
Powering on the system .................................................................................................... 7 
Powering off the system ................................................................................................... 8 
Starting up the M3 software .............................................................................................. 8 
Starting up the Hypack software ..................................................................................... 10 

APPENDIX A: SUPPLEMENTAL PROCEDURES ..................................................... 13 
M3 software setup procedures ........................................................................................ 13 

Configuring the sonar and sensors ............................................................................... 13 

Setting the sound speed ................................................................................................ 15 

M3 Sonar data recording and exporting ....................................................................... 16 
Hypack software setup procedures ................................................................................. 17 

Creating a Hypack project ............................................................................................ 17 

Configuring Hypack Hardware settings ....................................................................... 19 

Creating a matrix and survey lines in Hypack ............................................................. 25 

Performing a patch test ................................................................................................. 27 

 



M3 BATHY / Quick start guide: Using Hypack 

2   922-20007004/1.5  

About this manual 

Purpose 
The purpose of this document is to provide the necessary instructions and reference 
diagrams required to properly configure the M3 and Hypack software. Installation of all M3 
hardware should be complete before reading this guide. 

Target audience 
The reader is expected to have a background in multibeam echo-sounder bathymetry survey 
techniques and experience using Hypack software. 

Licence information  
The M3 Software is included with the M3 BATHY system. Updates are available free of 
charge and can be downloaded from: http://www.km.kongsberg.com/mesotechsoftware. 

A Hypack® license is supplied as part of the standard M3 BATHY system. Updates can be 
obtained directly from Hypack®. Annual software maintenance fees apply to the software 
package for updates and support.  

Software version 
The software references and associated figures in this manual are using: 

• M3 Software v1.62 

• Hypack® 2016 

http://www.km.kongsberg.com/mesotechsoftware
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Registered trademarks 
• M3 Sonar® 

• Hypack® 

 



M3 BATHY / Quick start guide: Using Hypack 

4   922-20007004/1.5  

M3 BATHY 

This is the quick start guide for the software configurations of the M3 BATHY shallow 
water bathymetric survey system. 

This manual does not give a detailed description of every function in the M3 and Hypack 
software. Refer to the M3 user manual and Hypack user manual for detailed information. 

Topics 
• System description on page 5  

• System diagram on page 5 

• Support information on page 6 
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System description 
The M3 BATHY is a compact, lightweight multibeam echo-sounder system for shallow 
water survey. The M3 BATHY system software package includes the M3 software and the 
Hypack software. 

The M3 software controls the M3 multibeam echo sounder, acquires sounding data and 
exports the sounding data to the Hypack software. 

The Hypack software receives the sounding data from the M3 software through UDP with 
the Kongsberg Mesotech M3 driver. 

System diagram 

 
Figure 1. System Diagram 
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• All sensors — including GPS, Gyro, Motion Reference Unit (MRU), and ZDA — 
need to be connected to the Hypack software. It’s optional to split the sensor data to 
the M3 software for M3 local recording. 

• The M3 software sends sounding data through EM .ALL format over UDP. 
• If the Hypack software and M3 software are running on separate computers, split 

the ZDA string to the Hypack software and M3 software so that both computers’ 
time can be synchronized with ZDA time. 

• If the Hypack software and M3 software are running on the same computer, 
configure the ZDA string only to the Hypack software. 

Support information 
 

If you require assistance with your M3 BATHY system, please contact: 

Kongsberg Mesotech Ltd. Phone: +1 604 464 8144 

Email: U km.support.vancouver@km.kongsberg.com U 

If you require assistance with Hypack® software, please visit the Hypack support website: 
http://support.hypack.com/support/ 

mailto:km.support.vancouver@km.kongsberg.com
http://support.hypack.com/support/
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Getting started 

Topics 
• Powering on the system on page 7 

• Powering off the system on page 8 

• Starting up the M3 software on page 8 

• Starting up the Hypack software on page 10 

Powering on the system 
1. Starting up the Sonar Processor laptop: 

a. Power on the laptop. 

b. Log in to Windows. 

2. Powering on the Surface Interface Unit: 

a. Plug the AC to DC power brick into the breakout box connected to the Surface 
Interface Unit. 

b. Confirm the power indicator light on the Surface Interface Unit’s power supply is 
turned on. 

c. It will take the Motion Reference Unit (MRU) up to 15 minutes before full accuracy 
is achieved. 

Note! If the vessel has high dynamics during start-up, the MRU may run into problems. 
At worst, the alignment must be redone by restarting the MRU. High dynamics 
during start-up means that the MRU has moved up to ±10 degrees on all the 
orientation axes. 

d. The GPS will also need up to 15 minutes to acquire all satellites and achieve full 
accuracy.  
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Note! If the Surface Interface Unit (SIU) is powered on before the processor laptop, 
the SIU will start sending GPS strings to Windows. There is a known issue with 
Windows where it may detect the GPS string as a serial mouse and the mouse 
cursor will jump around. To fix this, turn off the SIU or disconnect the GPS, 
restart Windows, then turn on the SIU or connect the GPS. 

Powering off the system 
1. Powering off the Surface Interface Unit simply requires unplugging the power cord or 

switching off the breaker to the Surface Interface Unit’s AC to DC power-supply brick. 

2. Powering off the Sonar Processor Laptop: 

a. Save your settings, then close the Hypack and M3 Software. 

b. Shut down Windows. 

Starting up the M3 software 
1. Start the M3 software: 

a. Double click the M3 software icon on the Windows desktop. 

2. Confirm that the M3 Sonar is connected to the system: 

a. Select Setup menu > System Configuration > Devices > Sonar Setup. 

b. Click the Discover Sonar Heads button. 

c. Confirm that the Sonar Head appears in the Online Sonar Heads list. If not, check 
the Ethernet connection between the laptop and the M3 Sonar Head. 

 
d. Select the Sonar Head listed under Online Sonar Heads and click on the button Use 

Discovered Head. 

3. Confirm that the mounting offsets have been entered correctly: 

a. Click on the Deployment tab > Mounting Offsets in the System Configuration 
window.  
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b. Confirm that the offsets are entered according to the Configuring the sonar and 
sensors section on page 13. Default configuration for M3 BATHY – Downlooking  
is shown in the figure below. 

 
c. Close the System Configuration window. 

4. Confirm that the M3 Software data export and profiling settings are correct: 

a. Select Setup menu > Preferences. 

b. In the Preferences window, confirm the IP address and port settings are configured 
according to the M3 Sonar data recording and exporting section on page 16. The 
default values are shown in the figure below. 

 
c. Close the Preferences window. 

d. Select File menu > Exporting Format, then confirm the format is set to “Profile 
Point (.all)”. 

e. From the Profile Settings window (if not open, select Display menu > Profiling 
Settings), confirm either “Image and Profile” or “Profile Only” is selected. 

f. From the Sonar Apps menu, confirm that either “Profiling” or “Profiling - Fast” is 
selected. 

 

5. Connect the M3 Sonar and start exporting: 

a. Select Setup menu > Connect to activate the M3 Sonar Head. 

b. Confirm that the sonar image updates. 

c. Click on the Export Data button located in the the top-right menu of the sonar 
screen. 
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Starting up the Hypack software 
1. Insert the Hypack dongle into a computer USB port. 

2. Start the Hypack software: 

a. Double click the Hypack 2016 icon on the Windows desktop. 

3. Confirm that data is being received from the Hypack software: 

a. Select Preparation menu > Hardware Setup, then click on the Kongsberg 
Mesotech M3 driver entry under HYSWEEP Survey. If the hardware is not 
configured, see the section Configuring Hypack Hardware settings on page 19 to 
configure the HYSWEEP Hardware.  

b. Select the Connect tab and click the Network Test button. 

 
c. Click the UDP Connect button on the Network Connection window to confirm the 

received UDP data from the M3 software. 

d. Close the Network Connection window. 

4. Confirm that data is being received from the GPS: 

a. Click on the GPS NMEA-0183 entry under Boat (on the left side of the HYPACK 
Combined Hardware window). If the hardware is not configured, see the section 
Configuring Hypack Hardware settings on page 19. 

b. Select the Survey Connect tab, then click the Test Device button. 

c. Confirm that GPS data is being received in the test window. 

5. Check that the following survey requirements have been met (for more details, refer to 
the Appendix): 

a. Geodesy parameters have been entered. 
b. A background chart has been added. 
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c. Survey lines and a matrix have been plotted. 

6. Collect Bathymetry data using Hypack: 

a. Click the whale icon, then click HYPACK Survey and HYSWEEP Survey to 
start the survey. 

 
b. If this is your first time starting a survey, set the source for Heave and Pitch/Roll 

data to the Motion Reference Unit. You only need to do this procedure once: 

- From the HYSWEEP Survey window, select View menu > Device Selection. 

  
 
- From the Device Selections page, click the Select Boat Corrections tab. 
- Select Hypack Navigation for the Heading, select TSS DMS for Heave, and 
select TSS DMS for Pitch/Roll 
- Click OK. 

 



M3 BATHY / Quick start guide: Using Hypack 

12   922-20007004/1.5  

 
c. Survey line recordings are displayed in the Data Display window. The file names 

should be written in a notebook during the survey for later reference. 
d. Start and end logging using the buttons in the Hypack Survey control window 

shown below: 

 

Note! You can also use <CTRL + S> to start logging and <CTRL + E> to end 
logging. 

Note! See Hypack user documentation and training material for how to perform a 
patch test and how to collect survey data. 
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Appendix A: 
Supplemental Procedures 

Topics 
• M3 software setup procedures on page 13 

• Hypack software setup procedures on page 17 

  

M3 software setup procedures 

Configuring the sonar and sensors 
1. Run the M3 software. 

2. Set up the sonar: 

a. Click Setup menu > System Configuration. 

b. Select the Devices > Sonar Setup tab. 

c. Click Discover Sonar Heads. 

d. Click Use Discovered Head to accept. 
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e. Set the Trigger mode to synchronize the M3 with another acoustic device. Set the 
trigger mode to Master to send out a sync pulse so that the other acoustic device 
can be triggered by the M3 sync pulse. Set the Trigger mode to Slave to be 
triggered by the sync pulse from the other device. For M3 BATHY system, the 
default is set to Master.  

 
 

3. Set up the mounting offset: 
a. Click Setup menu > System Configuration. 
b. Select the Deployment > Mounting Offsets tab. 
c. If the M3 is installed as connector towards bow, select Downward from the 

Orientation. If the M3 is installed as connector towards stern, select Downward 
Inverted from the Orientation. If the M3 is installed as sideways looking to scan 
vertical structures, enter the Roll angle.  

 
Figure 2. Downward Mounting 
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Figure 3. Downward-Inverted Mounting 

 
Figure 4. Downward Mounting with 45-degree roll and two poles 

Note! The M3 BATHY default mounting configuration is Downward.  

 

4. Save the deployment configuration: 
a. Click the Master Reference tab. 
b. Click the Save As button.  
c. Enter a new configuration name and click OK. (e.g. Downlooking Mode) 
d. The configuration file is saved under the M3 software installation folder: 

..\KML\M3_Vxxxx\bin\Settings.  

Note! Changing values in the Master Reference or Mounting Offsets tabs changes the 
values for the current configuration. If you want to create a new configuration, 
first click Save As or New, then modify the parameters. 

Setting the sound speed 
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1. Measure the sound velocity at the Sonar Head or calculate the harmonic mean from the 
sound velocity profile. 

2. Run the M3 Software. 

3. Click Setup menu > Preferences. 

4. Enter the Variable: Sound Velocity. 

5. Click Close. 

M3 Sonar data recording and exporting 
1. Display Profiling Settings by selecting Profiling Settings from the Display menu. 

2. Select Profiling or Profiling – Fast application mode from the Sonar Apps menu. 
Profiling – Fast mode provides a much higher ping rate but is not recommend to be 
used for a short range of less than 5 meters. 

3. Choose Image and Profile or Profile Only to enable profile points on the sonar image 
window. 

 
4. Select File menu > Exporting Format > Profile Point (.all). 
5. Select Setup menu > Preferences to configure the UDP port and IP address. 
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6. Enter the UDP port in Port for .ALL format. This is the UDP port set in the third-
party software to receive the .ALL data from the M3. Set the Remote IP Address; this 
is the IP address of the computer running the third-party software. If the third-party 
software is running on the same computer as the M3, enter 127.0.0.1.  

7. Close the Preferences window. 

8. Click the Export Data button in the top-right menu to enable UDP .ALL data export. 
9. Select Setup menu > Connect to activate the M3 Sonar Head. 

10. The M3 data-acquisition screen should be similar to the screen below: 

 

Hypack software setup procedures 
The following configuration steps are required to interface Hypack for data acquisition. 
This document uses Hypack software version Hypack 2016. 

Creating a Hypack project 
1. Run Hypack 2016, then click on the File menu > New Project to create a new project 

(for example, M3 BATHY Harbor Acceptance Test). 

2. Set the Geodesy by selecting Preparation menu > Geodetic Parameters. 

a. Set the Grids and Zone for the project location. 
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b. Click OK when done. 

c. Save the project by selecting the File menu > Save Project. 
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Configuring Hypack Hardware settings 
1. Configure Hypack for a GPS input: 

a. Select Preparation menu > Hardware Setup. 

b. Click on Boat, select the GPS NMEA-0183 driver, then click the Add button. 
Remove other devices in the list, such as the default HYPACK File Simulation. 

  
c. Click on GPS NMEA-0183 in the Hardware list on the left. 

d. Click the Survey Connect tab, then click the “…” button next to Device 
Connection. 

 
e. Select Serial for the connection type.  

f. For the M3 BATHY system, set the Speed to 115200, and Port to COM12. 
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g. Click OK. 

h. Click the Offsets tab, then enter the offsets from the M3 receive array to the GPS 
primary antenna. For the M3 BATHY system, set Starboard (X) = 0 and Forward 
(Y) = -0.266 m.  

i. Measure the distance from the waterline to the GPS primary antenna, positive 
downward. Then, enter this distance as a negative number for the Vertical (Z) 
value. 

 
2. Configure HYSWEEP Hardware: 

a. Click on Hardware (on the left). Under HYSWEEP Survey, check Include to 
include Hysweep hardware setup.  
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b. Click on HYSWEEP Survey (on the left), then select Kongsberg Mesotech M3. 

Click the Add button to add the device, then click the Setup button. 

 
c. Select Use Raw Data in the setup window, then click OK. 
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d. Select the Offsets tab to configure the transducer Position offsets. Leave the 
Rotation offsets all at zero. For the M3 BATHY system, set Starboard (X) = 0 and 
Forward (Y) = 0. 

e. Measure the distance from the waterline to the receive array, positive downward. 
Then, enter this distance as a positive number for the Vertical (Z) value. 

 
f. Select the Connect tab to configure the port and IP Address to match the M3 

computer IP address and the M3 .ALL UDP exporting port. (The default local-host 
configuration is: Internet Address 127.0.0.1, Port 20002). Click the Network Test 
button to open the Network Connection page. 

 
g. Click the UDP Connect button to confirm the received UDP data from the M3 

software.   
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h. Click on HYSWEEP Survey (on the left), then select TSS DMS. Click the Add 

button to add the device. 

 
i. Select the Connect tab to configure the serial port and settings. For the M3 BATHY 

system, set the Baud rate to 115200, and the Port to COM10. 

 
j. Select the Offsets tab to configure the MRU offsets. For the M3 BATHY system, 

set Starboard (X) = 0 and Forward (Y) = 0. 
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k. Measure the distance from the waterline to the MRU reference point, positive 
downward. Then, enter this distance as the Vertical (Z) value. 

 
l. Click File menu > Save to save the configuration. 
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Creating a matrix and survey lines in Hypack 
The Hypack Line Editor is used to layout lines that will be used to cover a survey area. 
Recording in Hypack can be configured to automatically begin recording when the vessel 
reaches the start of the line. Recording can also be stopped automatically when the vessel 
reaches the end of the line. 

The Matrix Editor is used to layout the region where the bathymetry data will be 
displayed in the map view during the survey and in the Hypack window. The cell height 
and width are defined in the matrix. 

1. Layout the survey lines in Hypack: 

a. Select Preparation menu > Editors > Line Editor. 

 
b. From the Line Editor, click Add Line to define survey lines:  

- Click Add Point, Insert Point, and Offset to add lines by entering coordinates. 

- Click Cursor to draw survey lines.  

- Click Offsets to add parallel lines. 

 
Figure 5. Survey lines displayed in the Hypack main window 
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c. In the Line Editor window, click File menu > Save when done. Enter a file name for 
your survey lines, then click Save.  

2. Layout a matrix area around the survey lines: 

a. Open the Matrix editor by selecting Preparation menu > Editors > Matrix Editor. 

b. Set the Matrix Type to HYSWEEP. 

c. Set the cell width and height to 1.0 m. 

d. You can adjust the matrix dimensions by rotating and positiong the green rectangle 
around the survey lines. 

 
e. When you are done, click File menu > Save in the Matrix Editor window. Enter a 

file name for your matrix, then click Save. 
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Performing a patch test 
Once the hardware tests are complete, perform a calibration test to measure the Latency, 
Pitch, Roll and Yaw. Set up the patch-test survey lines before leaving the dock to save time 
by using the nautical chart to choose appropriate areas for each test.  

Note! When making the planned lines in Hypack, they should be 100m (300ft) long. See 
Hypack user documentation for more information about patch tests. 

 1. Record Latency calibration data:  

a. Select one survey line with a feature like a wreck, rock 
outcrop, or slope. 

b. Run the survey line in the same direction at one speed. 
c. Run the same survey line in the same direction at twice the 

speed of the first run. 

2. Record Roll calibration data: 

a. Select one survey line on a flat sea floor with a depth of 30m 
or deepest available area. 

b. Run the survey line at the same speed in opposite directions. 
c. Record a second set of lines. 

3. Record Pitch calibration data: 

a. Select one line on sloped seafloor. 
b. Run the line at the same speed in the opposite direction. 
c. Record a second set of lines. 

4. Record Yaw calibration data: 

a. Select two lines offset by half the swath width. The overlap 
of the two runs should cover an object such as a wreck, rock 
outcrop, pipeline, or trench line. 

b. Run both lines in same directions and at the same survey 
speed. 

c. Record a second set of lines. 
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